Start a new topic

Windows Android Studio : Application Crash when I launched emulator of Pepper


I have a seriously problem with Android Studio and the plugin of Pepper, especially with the emulator.

For few months I have the same problem: my android studio crash when I click on Emulator Icon (Orange icon on toolbar).

I tried everything : uninstall android studio, uninstall plugin of pepper but I have always the same problem.

When I run my android studio as administrator, sometimes it works...

I have the latest version of Android Studio (see PJ).

Thanks for your help


3 people have this problem

Hello Arnaud, 

Which OS are you using when working with Android Studio  ?


Hello Clement,

Thanks for your answer, it's windows 10.

And I checked everything on this documentation :

Thanks :)


Ok I see, indeed it should work... 

Have you had the chance to try it out with an older version of Android Studio, does the same issue occur ? 

I have tested on Arctic fox I have the same problem.

It seems that the problem is on naoqi_bin , qilaunch and publicsd instance (when I have investigate process).

So is it possible to have the command to launch emulator from my powershell ? Because I found a way to have the robot viewer with command line but I couldn't find the way to run the android emulator from command line.

My goal is to reproduce the action when I clicked on the robot emulator tool in Android Studio but in my powershell to avoid the software to crash !



Hi Arnaud, 

I have found the following command line here : (

emulator -avd avd_name [ {-option [value]} … ]

Which could potentially worked, name of the AVD is "Pepper" but emulator.exe wouldn't recognize it by default I think. 

In parallel, Softbank is currently working on a workaroundfor this issue as several customers are experiencing it. 

Hello Clement

Yes I have found this command line and I tried with Pepper name but it's not recognized indeed :

C:\Users\a.mignotte\AppData\Roaming\Softbank Robotics\RobotSDK\Common\emulator.29.0.11\emulator> .\emulator.exe -avd Pepper

emulator: ERROR: Unknown AVD name [Pepper], use -list-avds to see valid list.

HOME is defined but there is no file Pepper.ini in $HOME\.android\avd

(Note: Directories are searched in the order $ANDROID_AVD_HOME, $ANDROID_SDK_HOME\avd and $HOME\.android\avd)

Ok I hope Softbank found a solution quickly.

Thank you very much for your help.


Hello Arnaud, 

To help investigate, could you : 

Thank you in advance !


Hello Clement,

thank you for your answer.

In PJ the files you asked me.

I hope it will help you.

And yes I have checked all troubleshooting but it seems to be ok.

Thank to you


(2.15 KB)
(166 KB)

Dear Arnaud, 

I was discussing this issue with the investigation team from Softbank, could you actually send me again the Pepper plugin settings, it should look like the attached image. 

You can find it in File => Settings => Pepper plugin settings
If you change the AVD option you can sometimes make it work with less issues (by selecting Software for Graphics for example). 

Can you also go in About and then copy paste the info (Android version, OS, etc ...) you have the option to do so when hovering with your mouse over the frame that appears. 

Thanks in advance ! 


Hello Clement,

yes of course, here, the information asked :


And for About version : 

Android Studio Bumblebee | 2021.1.1 Patch 2

Build #AI-211.7628.21.2111.8193401, built on February 17, 2022

Runtime version: 11.0.11+9-b60-7590822 amd64

VM: OpenJDK 64-Bit Server VM by Oracle Corporation

Windows 10 10.0

GC: G1 Young Generation, G1 Old Generation

Memory: 3072M

Cores: 8

Registry:, ide.balloon.shadow.size=0

Non-Bundled Plugins: (1.5.3), com.thoughtworks.gauge (211.6693.111), org.jetbrains.kotlin (211-1.6.20-release-275-AS7442.40), com.developerphil.adbidea (1.6.4), com.chrisrm.idea.MaterialThemeUI (6.7.2), org.intellij.plugins.markdown (211.7142.37)

Thanks to you for your help


I have not found a fix for the problem with the emulator for myself but a workaround:

First, I uninstalled the Pepper SDK, so I deleted everything. In the AppData/Roaming folder there is the Softbank Robotics folder, which I deleted completely.

Then I reinstalled the entire SDK.

Then the tools and the emulator have to be downloaded again via the SDK Management Tool from Softbank. All the stuff then ends up in the AppData/Roaming/Softbank Robotuics folder. I then made a copy of the Softbank Robotics folder and simply wrote clean behind it (Softbank Robotics - Clean). This gives me a clean and unused version as a backup.

When you start the emulator for the first time, you at least get a working emulator. It may happen that Android Studio crashes, but the emulator remains. Then you can simply start Android Studio again and open the Robot Browser, for example, and select the local Pepper. Then it may happen that Android Studio crashes again and you have to start it again. In the end, you will have an executable version of the emulator.

Now comes the catch and the reason why we make a backup of the Softbank folder. The next time you try to start the emulator you will have the old version again, so Android Studio crashes and nothing happens. Apparently you can only get an emulator to run that has never been started.

So I wrote a small script (.bat) which first kills all Qi processes and then deletes the Softbank folder in AppData and copies the clean version over it again. Then you have an untouched emulator again.

I have attached the script here, the following line must be adapted with the folder name:

Xcopy "Softbank Robotics - Clean" "Softbank Robotics" /E /H /C /I

Here I use the folder "Softbank Robotics - Clean" where I saved my clean version.










1 person likes this
Hi Clement, there is any update on this? In my android studio log, in crashes when connecting to but without error trace or anything. Any advice will be welcome

Hey issue is still happening, any updates?

2 people like this
Login or Signup to post a comment