Start a new topic

Tablet not responding

Hi, I'm using a Pepper that other people used to manage a couple of years ago. I'm not sure about the state of the software on the robot, but it recognises faces and respond to movements. Also, I have been able to run simple programs through Choreographe. I have had the robot change LED colours and present an image on the tablet. My problems are:

- The tablet is on the "bubbles" animation and does not respond to touch (the touch on the tablet  does work as I tested it with Choreograph).

- The version of NAOqi is, I tried to update through the web interface, but it says everything is up to date, and I can't update to 2.9 (and the instructions say to use the tablet for it)

- I can't install some missions that are supposed to work on NAOqi 2.5 on the Pepper (Airport check-in,  for example), but the website client command centre says: the selected robot is not compatible with the available version of the mission.

Should I do a factory reset and expect the robot and the tablet to be updated to current versions? Is an app missing from the robot that does not allows me to interact with the tablet?

Thank you!


1 person has this question

same issue here

Hello Simon,

Your Pepper is a Python Pepper, which is programmed with Choregraphe. The latest NAOqi version for the Python Pepper is 2.5. If you want to update the robot to 2.9, you will then have an Android Pepper that you have to program via Android Studio.

I assume you have logged in with your account on the Command Center portal, which is used for the Android Pepper.

Log in once on the Aldebaran Cloud. Here you can manage the Python version of your robot and assign apps from the store.

The "bubbles" are displayed by default on the tablet if you do not display anything via your behaviour. Here you can display an image, for example, there is a box for that. 

If you want to work with the tablet, you have to create an html folder for it in the project. Pepper runs a web server that can be accessed from outside and from the tablet. You can then display your HTML page on the tablet:

If you want to collaborate with your programme, e.g. by using the memory key system, you can use the JavaScript interface:

Hi Simon,

irst of all it would be helpful to know if its a 1.8 or 1.8a Pepper. The 1.8 version (the newer model) has 4 holes in the Back of his head. If there are only 2 holes it is the older 1.8a model.

If you want to upgrade the robot to naoqi 2.9 (Java version) you have to know that it is no compatible any more with Choregraphe. You will have to use Android Studio for programming afterwards. If the robot is running 2.9 an downgrade will not be possible any more.

The upgrade must be provided by URG. If you want, I could assist you with this.

Kind regards


Hi Friedrich,

thank you for the answer. This Pepper is a 1.8a model with only 2 holes in the back. Looking at Naoqi 2.9 differences to 2.5 I think that we will stay in 2.5 as we use Choregraph regularly.

Now my question would be how to restore the functionality to use the tablet. I don't get any response by touching it and I can't install 2.5 version missions on the robot (I get a compatibility issues message when trying through the command centre).

Best regards,


Hi Simon,

Regarding the interaction with the tablet there could be many reasons. Perhaps a factory reset is the best way to get an working system, if there is no problem with the tablet hardware.

Here is a link to the old solutions section with anexplanation how to do a factory reset for a Pepper with 2,5:

Perhaps this will solve your problem with the tablet.

Kind regards



Hi Lukas and Friedrich,

thanks you for the input. I have factory reset the robot. There were a couple of error messages during the reset:
“unable to contact the server. 

Please reboot to solve this issue”.

Connection no Naoqi lost...

After a while, I was able to initialise the robot through the tablet by entering a new password, language, wifi etc. It installed "config launcher" mission. I rebooted the robot and blue lights appeared on the shoulders, then blinking white lights. The tablet showed a single circle that grows and shrinks. After around 10 minutes the robot boots up and I can work with it. This long boot is happening each time I turn the robot on.

- Is there a way to fix the long boot?

The other thing that we are trying to decide is if we go to Naoqi 2.9. I understand the changes in the programming language and IDEs. What I would like to ask you:

- Are there apps like the "follow me" ( or the missions MapLocalize&Move available for Naoqi 2.5, Pepper 18a? I tried to install the mission MapLoacalise but it says the robot is not supported (and that's the case for most missions at the store)

- I also tried the apps from as Lukas pointed out. I could install a very limited number of them as most of them are not compatible with my robot. Is Naoqi 2.5 still supported? or all/most the development has moved to 2.9?

Thank you and best regards,


Hey Simon,

I don't think there is a simple fix for the long boot times, in fact I suspect it has to do with the connection to the Aldebaran servers in some places, but I'm not sure.

The apps you mentioned have to do with the navigation of Pepper, these apps basically only work with the Android version of Pepper. Another problem here is the 1.8a model, which does not yet have the stereo cameras of the 1.8 model. It is possible to run the navigation apps on a 1.8a Pepper, but the navigation will then not work properly, as it is dependent on the features mentioned from the 1.8 Pepper.

The NAOqi version 2.5 is the predecessor of the current Android version; as far as I know, there is currently no further development in either case.

In the field of Pepper, most development work is now only done in Android.

Hi Simon,

can you contact me by mail please?



Login or Signup to post a comment