Start a new topic

Choreographe animation mode

Hello, We are trying to use the "Animation Mode" on Choreographe a Nao 6 running 2.8.7, but the icon only goes from Green to Yellow, not Red. Here are the steps: 1. Create a new Choreographe project. 2. Add a timeline and enter into it. 3. Awaken robot 4. Click "Animation mode" and click OK on the dialog box that shows up. What we expected to see: The Animation Mode icon goes from Green to Red and we could start posing the robot similar as documented in Choreogrape. What happened: The Animation Mode icon went from Green to Yellow and the robot remains stiff. Is there something that we have overlooked. I remember this working on this Nao previously, albeit it was running an earlier version of Naoqi.

Hello Treton, 

It's a known issue that is still under investigation, but one of the possible lead could be that it is linked to the sensors of the hand that may detect contact when there is none. This is due to a hardware limitation of the product that is not corrected yet. 

However, have you tried going back to 2.8.6 (I assume you were using this version of NAOqi before 2.8.7 ?) to see if it is working again ? 



Hello Clement, Do you mean downgrading Nao to 2.8.6? Or using Choreographe 2.8.6? I didn't know we could downgrade the Nao (or is it more of a factory reset to 2.8.6?) Best regards, -- Trenton

Hi Trenton, 

You can go to the ADE ( and set a manual update to 2.8.6 : 

You will then need to downgrade your NAO through the webpage. 


Did it worked?

Unfortunately, I did not get a chance to try this out last summer, and the robot where this was happening is currently at another location. I'll be collecting the robot in late June and will try it out then.

I will say that I tried this with a different NAO 6 and I could not reproduce the issue. So, I haven't had a chance to follow this up more.

Login or Signup to post a comment